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Introduction 
Thank you for downloading this invaluable report. 
 
This guide contains our distilled, concise wisdom regarding the many common problems 
we’ve encountered, observed, and fixed over the years. 
 
In the pages that follow, you’ll find details of 52 specific problems, why each item is important, 
plus examples and advice on how to avoid the pitfalls.   
 
This white paper contains extensive explanations, worked examples, screenshots and 
illustrations. 
 
We’ve assumed an intermediate level of prior knowledge but even if you’re new to Excel, 
you’ll still find plenty of useful tips. 
 
Take your time in reading the guide and ensure you keep it handy for future reference. 
 
By avoiding the problems we’ve noted below, your spreadsheets will be MILES ahead of 
those around you and your productivity will absolutely SOAR! 
 
Enjoy your superior spreadsheets! 
 
 
The Access Analytic Team 

About the Author 

JEFF ROBSON 

Qualifications and Background 

B.Comm (Accounting & Information Systems), CISA, AFin, AIMM, 
Excel Expert 
 
Jeff Robson is the Principal Consultant of Access Analytic Solutions, a Perth-
based consulting company that provides financial modelling services in model 
development, audit/review, and training. 
 
Jeff holds a Certified Information Systems Auditor from the Information Systems 
Audit and Control Association.  He has 15 years experience with Microsoft 
Excel, 6 years experience in Information Systems Audit, and worked for 4 years 
in external audit. 
 
He has been involved in many Excel development projects for clients around the 
world including sophisticated financial modelling, auditing and review, and 
advanced macro programming.   
 
Access Analytic is the Information Systems audit partner for a number of chartered 
accounting firms in Perth and performs IT system reviews, Information Systems audit and 
control reviews, and systems selection and implementation for a wide variety of clients. 
 
Direct: +61 8 6210 8500 or +61 4 1258 1486 (0412 581 486 in Australia) 
jrobson@accessanalytic.com.au  
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Using this Guide 

SPREADSHEET PROFESSIONAL 

In this guide, you’ll see many references to Spreadsheet Professional, a powerful Excel add-
in for testing and documenting spreadsheets.   
 
For more information about this product and how it can benefit you, visit 
http://www.accessanalytic.com.au/services_spro.php  

MORE HELP 

Access Analytic provides Financial Modelling, Management Reporting and Training services 
for companies that need to make decisions with confidence.  We have provided solutions to 
companies all over the world and have worked with spreadsheets for over 15 years.   
 
To read a sample of testimonials from our clients, visit 
http://www.accessanalytic.com.au/success.php 
 
To learn more about the points discussed in this guide or how Access Analytic can assist your 
business by developing customised solutions for you, visit  
http://www.accessanalytic.com.au/services_excel.php  

KNOWLEDGEBASE 

We have a fully-searchable Knowledge Base available with hundreds of articles that we’ve 
written over many years.  This is a great resource for getting insights on Excel and financial 
modelling that you won’t find anywhere else on the web! 
http://www.accessanalytic.com.au/kb.php  
 
 
 

http://www.accessanalytic.com.au/services_spro.php
http://www.accessanalytic.com.au/success.php
http://www.accessanalytic.com.au/services_excel.php
http://www.accessanalytic.com.au/kb.php
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52 Easy Ways to Prevent 
Spreadsheet Problems 

FORMULAS & FUNCTIONS 

1. Avoid hard-coding values in formulas – enter the data in cells then reference these in your 
formulas. 

Hard-coding values in formulas is often a “quick and dirty” fix for changing the way a formula 
works and is commonly a source of error.   
 
Formulas should use a value stored in another cell rather than placing the value directly into 
the formula.  This way, you can always see the values being used in the formula and when 
you change the input data, the formula updates correctly.   
 

 
 
Both “Price inc Tax” numbers look the same but if you had 1000 items and the tax rate 
changes, it would be time consuming to change every formula and check this was correct if 
each formula contains “*1.1”.  It’s much easier and more readable to place the tax rate in a 
different cell and reference this. 
 
This type of error is identified by “Spreadsheet Professional”, a powerful Excel add-in for 
documenting and testing spreadsheets that is sold by Access Analytic. 
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2. Don’t mix formula and data entry areas together.  Consider having separate areas that 
are readily distinguishable for data entry, calculations, and output. 

Mixing formulas and data together is another very common source of errors.   
 
By having separate areas (or ideally separate sheets) for data entry, calculations, and output, 
your spreadsheet is more organised, and you know what a cell contains just by looking at it.  
It’s often useful to shade all data entry cells a particular colour (eg light yellow, or grey, etc) to 
show users exactly where they can and can’t enter data. 
 
Then, when you need to update your spreadsheet, each area can be updated without 
affecting the other areas that depend on it.  In addition, you won’t accidentally overwrite a 
value or formula because you didn’t know it was there. 
 
Spreadsheet Professional helps to identify these types of errors via its “Spreadsheet Painter”, 
and “Spreadsheet Map” tools. 

Acme Widgets Ltd - Annual accounts

Period Q1 Q2 Q3 Q4

Sales 2800 3000 4000 5000

Cost of sales 1200 1000 1200 1300

Net cost of sales 1600 2000 2800 3700

Overheads 1600 1200 1200 1200

Profit before tax and interest 0 800 1600 2500

Opening cash balance 200 200 764 1895

Average cash balance 200 600 1564 3145

Qtrly interest rate upto $10000 1.0% 1.0% 1.0% 1.0%

Qtrly interest rate over $10000 1.5% 1.5% 1.5% 1.5%

Qtrly interest rate over $20000 2.0% 2.0% 2.0% 2.0%

Interest 2 6 16 31

Profit before tax 2 806 1616 2531

Tax rate 30% 30% 30% 30%

Tax 1 242 485 759

Profit after tax 1 564 1131 1772  
Which of these cells contain formulas and which contain numbers? 

Spreadsheet Professional shows you automatically: 
 

Acme Widgets Ltd - Annual accounts

Period Q1 Q2 Q3 Q4

Sales 2800 3000 4000 5000

Cost of sales 1200 1000 1200 1300

Net cost of sales 1600 2000 2800 3700

Overheads 1600 1200 1200 1200

Profit before tax and interest 0 800 1600 2500

Opening cash balance 200 201 765 1896

Average cash balance 200 601 1565 3146

Qtrly interest rate upto $10000 1.0% 1.0% 1.0% 1.0%

Qtrly interest rate over $10000 1.5% 1.5% 1.5% 1.5%

Qtrly interest rate over $20000 2.0% 2.0% 2.0% 2.0%

Interest 2 6 16 31

Profit before tax 2 806 1616 2531

Tax rate 30% 30% 30% 30%

Tax 1 242 485 759

Profit after tax 1 564 1131 1772  
KEY: Dark Blue = label, Light Yellow = Number, Light Blue = Formula 
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3. Use absolute cell references and/or named ranges when copying formulas that refer to a 
particular cell or range.  Try to design formulae that will apply to a block of data, this 
makes it easier to copy. Hence you may have to use mixed references eg $A1 or A$1. 

If you use absolute cell references (eg “$A$1”) or named ranges (eg “TaxRate”) your formulas 
will always refer to the correct cell when you copy them and you won’t need to retype cell 
references after copying. 

4. Always document long formulas so you (and others) can remember what the formula 
does – especially those formulas with multiple nested functions and numerous layers of 
brackets. 

In general, the longer a formula is, the more likely it is that it will contain errors since it 
becomes increasingly difficult and time-consuming to test all possible permutations.  In 
addition, long formulas are particularly difficult to read and understand – even if you wrote 
them yourself.   
 
Instead, break long formulas into a series of shorter ones wherever possible and/or document 
the logic used via a cell comment.  
 

 
 
Spreadsheet Professional assists with understanding complex formulas via its Formula Tracer 
“bubble diagrams” and Translation Toolbar. 
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5. Check the offset you use in Vlookup, Hlookup, or other reference functions and be careful 
when you insert rows or columns in your Vlookup or Hlookup range. 

Vlookup and Hlookup are very useful and powerful functions however if you insert a new 
column of data into a Vlookup table and don’t amend your offset number your result will be 
totally incorrect (the same applies inserting a row of data into a Hlookup table). 
 
Assuming your lookup table starts in Column A, one way around this is to use the COLUMN 
function to get the correct offset rather than keying it manually. 
 

 
 
Spreadsheet Professional prompts you about Vlookup and Hlookup offsets. 

6. Be careful when inserting a new row or column of data just before a function such as 
Sum, Subtotal, Average etc – be sure to amend the function’s range. 

 

 
 

A new row has been inserted ready to enter Year 6 data but the SUM formula still only refers 
to the previous data range.  This must be changed manually. 
 
Spreadsheet Professional identifies data that has not been used in calculations and flags this 
as a potential error. 
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7. Watch out for circular references. 

Circular references are formed when a cell formula refers to itself (either directly or indirectly).  
In some circumstances, this can be useful (eg if you need to perform multiple iterations) but 
most of the time it means an error has occurred. 
 
Recent versions of Excel provide a toolbar that automatically pops up to assist you in locating 
the error.  In older versions, you can use the Auditing toolbar to track this down. 
 

 

8. Never clear a cell using the space bar, use the Delete key instead. 

If you use the space bar to clear a cell’s contents, the cell will appear empty on your screen 
but Excel doesn’t consider it to be empty.  For Excel, the cell still contains a single character 
of text. 
 
This causes problems when you use the cell in number calculations. 
 

 
Errors occur because B3 contains a space rather than  

 being cleared by pressing “Delete”. 
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9. Take care when using data of different units in formulas (eg m and km, l and ml etc).  
Ensure correct conversion is used or ideally perform the conversion in a separate 
calculation. 

When setting up your data entry variables, always be sure to include a description of what 
they are as well as the units. 
 

 
 
Spreadsheet Professional includes functions that setup a data entry sheet in this standard 
format. 

10. Ensure your spreadsheet can handle unusual situations such as zero or text values in 
cells (particularly where formulas use division).   

If your spreadsheet is going to be used by others (particularly people who aren’t computer 
literate) you need to make it as “idiot-proof” as possible. 
 
Some of the ways you can achieve this include: 

 Data validation (under Excel’s menus: Data > Validation).  You can apply this to a cell to 
specify that the data entered will only be accepted if it falls within a certain range eg a 
percentage must be between 0% and 100% (ie 1.00), or a product code must have 10 
alphanumeric characters etc.  This also allows you to set your own custom error alerts 
that are displayed if data entered doesn’t meet the required criteria. 

 

 
Sample screen for validating a percentage entry. 

 Error messages that only appear if an incorrect entry is detected.  This could be achieved 
with formulas such as =IF(A1>1000,”Error Detected”,””). 
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 Handle the error values within your formulas eg =IF(A1=0,0,B1/A1)  This will avoid any 
“#DIV/0!” errors that would otherwise appear if you try to divide by a cell containing zero. 

11. Don’t use SUM to calculate subtotals – use SUBTOTAL. 

If you need subtotals, SUM functions are a very inefficient and error-prone way to calculate 
these.  A far better way is to use the SUBTOTAL function. 
 

 
 
Even though there is a subtotal at B8, we can apply another subtotal function to the entire 
range B4:B9.  Excel recognises the other subtotal and doesn’t re-add this in the result at B10. 
 
This will work no matter how many previous subtotals there are and it is so much easier and 
simpler than using multiple SUM functions then adding each of these cells together. 
 
In addition, be wary of numbers with leading ‘. This causes the number to be treated as text 
and will not be included in calculations – even though it’s in a column of numbers. 
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PRINTING 

12. If you’re using manual recalculation, ensure you re-calculate before printing. 

If your file has automatic recalculation set (ie the default) you don’t need to worry about this 
point. 
 
However, if your file is set to manual recalculation and you don’t recalculate (by pressing F9, 
or going to “Tools > Options > Calculation > Calc Now”) before printing, your printout will 
show incorrect results. 
 
Your spreadsheet needs recalculating if you see the word “Calculate” in the status bar at the 
bottom left hand side of Excel’s screen. 
 

 

13. If you set a print area to show one portion of the sheet, don’t forget to change/clear this 
when trying to print the full sheet. 

A very common printing mistake is to set a print area then wonder why your printout doesn’t 
show everything you see on your screen. 
 
You can check if a print area is set by going to “File > Page Setup > Sheet”.  If a range has 
been set it will show in the “Print area” box.  You can then choose to clear this box or amend 
it as required. 
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14. If you use the print option “Fit to x pages wide by y tall”, your manual page breaks will be 
ignored. 

Another very common printing problem is to set manual page breaks (using “Insert > Insert 
Page Break”), but then select the option “Fit to x pages wide by y tall”, (under “File > Page 
Setup > Page > Scaling”) and wonder why your page breaks don’t work. 
 
If you want to use your manual page breaks, you must use the “Adjust to x% normal size” 
option. 
 
If you want to use the “Fit to x pages wide by y tall” option, you must accept Excel’s 
automatically generated page breaks.  Note that choosing this option doesn’t actually delete 
manual page breaks – they are still there and will re-appear if you choose the “Adjust to x% 
normal size” option. 
 
Note that to remove a manual page break, you need to go back to the Insert menu (yes, you 
read correctly!).  Click the cell in the top left hand corner of your page break and go to “Insert 
> Remove Page Break”. 
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NAMED RANGES 

15. When deleting range names or rows/columns containing these, ensure the names aren’t 
used in any functions or macros. 

If you delete a cell containing a named range (eg “TaxRate”), all the cells that refer to this will 
show the “#REF!” error.  This result will also be produced if you delete the range name itself 
(via “Insert > Name > Define > Delete”). 
 

 
 
Before deleting, use the Auditing tools (under “Tools > Auditing” or the Auditing toolbar) to 
look for any cells that still use the named range via “Trace Dependents”. 

16. When adding rows or columns at the end of named data tables, be sure to amend the 
range name. 

 
 
As this example shows, there is a named range called “tblSalesData” which refers to A2:B6.  
An additional row has been added but the named range has not been updated to include this. 
 
This then causes an incorrect result when the Vlookup function is used in A9. 
 
Another way to detect this type of error would be to amend the formula in A9 to 
=VLOOKUP(6,tblSalesData,2,FALSE)  By including the optional argument “FALSE”, the 
formula will only show a result if Excel finds an exact match for “6” in the lookup range.  In this 
case, an “#N/A!” error would be produced. 
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17. Avoid copying a formula that includes a named range from one spreadsheet to the other 
as this creates a hidden link between the workbooks. 

One of the most frustrating things is a file with links that you can’t find!  You can see what files 
are linked by going to “Edit > Links” but Excel doesn’t tell you which cells actually contain 
these links! 
 
There are a number of add-ins, that will seek these hidden links out and tell you where they 
are.  Spreadsheet Professional also includes this information as standard on one of its 
reports. 
 
In addition, when creating a range name use proper capitalisation such as “TaxRate” instead 
of “taxrate”.  The reason for this is that if you enter all your range names in lowercase, Excel 
will automatically convert them to uppercase if they are valid.  If Excel doesn’t recognise your 
range names you will see a #NAME? error displayed.  Any range names that are still in 
lowercase must have either been misspelled or haven’t been created yet. 
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FILES 

18. Use the Autosave add-in to avoid losing your work. 

This is relevant for Excel 2000 and below.  You can activate or check the status of the 
Autosave add-in under “Tools > Add-Ins”. 
 
Once installed, you can customise it under “Tools > Autosave”. 
 

 
 
In Excel 2002 (Office XP), the Autosave add-in has been replaced by Autorecovery which 
does a much better job and simply backs your files up rather than overwriting them 
accidentally (see below). 

19. When you use the Autosave add-in, do “Save As” with a new filename as soon as you 
open the file.  This will avoid accidentally over-writing the original file. 

Autosave is great in that it regularly prompts you to save your file (or just saves it 
automatically, depending on your settings).  However, Autosave overwrites the original file 
each time it saves and you don’t always want this. 
 
For example, you may have opened up a file you’re going to use as the basis for creating a 
new file, but you still want to retain the original one.  If you don’t do a “File Save As” as soon 
as you open the original file, you may accidentally overwrite it via Autosave. 

20. Make sure you save changes before quitting. 

The importance of this one is obvious!  If you click “No” when Excel asks if you want to save 
changes, your amendments are gone forever! 
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FORMATTING 

21. When cutting and pasting cells that have border formatting, ensure you reinstate the 
correct borders. 

If you copy and paste a formula, the default setting in Excel is to copy all formats and the 
formula to the destination cell(s). 
 
If you have special borders, and you use the normal copy and paste formulas, you may end 
up with breaks in your borders, which are painful to constantly reinstate. 
 
In the following example, the “Total Sales” formula was updated for Q1 then copied across to 
Q4.  However, when this occurred, the outline surrounding the data was broken. 
 

 
 
A better way of handling this is to use “Paste Special” then select “All except borders”.  This 
will copy the formula and all the other formats that have been set but will leave your existing 
borders in place. 
 

 
 

Another alternative is to use the Format Painter (the paintbrush icon near the copy and paste 
buttons) to easily copy all the formats from a correctly formatted cell/range to another 
cell/range. 
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22. Consider using “Center Across Selection” rather than “Merge Cells” – merged cells can 
cause issues during certain operations. 

In Excel versions prior to 97, the “Merge and Center” button  simply centered text across 
the range selected.  From Excel 97 onwards, it defaulted to merging the underlying cells and 
centering the text within the newly created merged cell. 
 
While merged cells are great for many applications they also cause problems in many 
situations including: 

 You cannot use the AutoFit feature on a column that contains a cell merged with cells in 
other columns.  Likewise, you cannot use AutoFit on a row that contains a cell merged 
with cells in other rows. 

 If you try to select cells and your selection includes a merged cell, you won’t be able to 
select just the cells you want. 

 

 
In this example, the “Acme Widgets Corporation” heading is in a merged cell (B2:F2).  If you 

try to select only the cells from C1:C9, this is what you get. 

 Copying and pasting merged cells can cause errors and unexpected results. 
  
Often, the advantages provided by merged cells are outweighed by the disadvantages.  As 
such, you may be better off using “Center Across Selection” if this is all you require because 
you will avoid all the problems noted above. 
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23. Watch out for long text entries that disappear under data cells but should be wrapped 
text. 

 
 
As this example shows, A8 actually contains the text “Cost of Goods Sold” but is only 
displaying “Cost of Good” because either the column is too narrow, or text wrapping has not 
been turned on (under “Format > Cells > Alignment” and check the “Wrap text” box). 
 
This could be deceptive if we were not aware the problem existed. 

24. Applying formatting to a sheet that has Auto Filter turned on can lead to some unexpected 
results when you remove the Auto Filter.  Best to turn it off first. 

If Auto Filter has been applied to a list of data, and formatting is done, only those cells that 
are currently visible will be formatted. 
 

 
 
In this example, a filter was applied to show only those records with Income > $30,000.  Then, 
with the filtered list, Column D was formatted in currency format.   
 
As you can see when the filter is removed, the two records that were not showing when the 
filter was applied have not been reformatted. 

25. Ensure your PC has the correct international settings – especially for dates. 

If your PC’s international settings have the date format of “mm/dd/yyyy” and you enter 
“31/12/2003”, Excel will not recognise the entry as a date and will automatically enter this as 
plain text.  As such, you won’t be able to use the date value in calculations and errors may 
arise. 
 
If your dates aren’t being recognised as dates by Excel, check your PC’s international settings 
under Control Panel to ensure these are correct. 
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CHARTS 

26. Limit the number of data series on a chart to 5 or less, otherwise it becomes too cluttered 
and cannot be easily understood. 

If you have too many data series on a single chart, you can’t really see what is going on. 
 
If you have more than about 5 data series to plot, consider creating 2 or more charts and 
splitting your series between these.  Maybe there are logical groupings that help in deciding 
which series belong on what charts. 
 
Alternatively, you may be able to sum a few data series and just plot the total.  You could 
always create further charts that show the detail of the summed series.  

27. Where chart data series have different scales, plot them on different axes. 

To allow for meaningful analysis, you need to be able to see the relationships between data 
and any trends that are apparent.  You can’t do this if one data series is many times larger 
than the other(s) as it will overpower your chart. 
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In this example, Income is so much larger than Age that the Age data doesn’t appear on the 
chart at all. 
 
This was fixed by plotting Age on the secondary axis (accessed by selecting the Age data 
series, then going to “Format > Selected Data Series > Axis” and choosing “Secondary Axis”). 

Acme Company Employee Data

$0

$10,000

$20,000

$30,000

$40,000

$50,000

$60,000

$70,000

$80,000

$90,000

$100,000

F
in

k
le

s
te

in

C
o
tt

o
n
b
a
ll

M
u
n
t

A
im

e
r

M
c
D

o
u
g
a
l

W
ig

g
le

s
w

o
rt

h

0

10

20

30

40

50

60

70

Income

Age

 
Note: in this example, the “Gap Width” (under the Format Chart Series “Options” tab) was 
increased to 500 to make the Age columns thinner. 

28. Ensure your axes scale and titles are correct.  Consider linking them to a cell. 
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Sales - Acme Company
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In this example, sales are stated in thousands of dollars as noted by the Y-Axis title.  If this 
wasn’t there, we would have no way of knowing whether sales were dollars, thousands of 
dollars, or even millions of dollars.   Unless we already knew the company’s business, it 
would be impossible to tell. 
 
To link a chart title to a cell, first create the titles under Chart > Chart Options > Titles.  Then, 
click on a title, press “=” then click the cell you want to link to and press Enter.  The title is now 
dynamically linked to this cell. 

29. If you’re using a chart type such as “line” ensure there is a logical relationship between 
the data. 

Line charts are very useful when there is a relationship between the items being analysed as 
you may be able to identify a trend.  But data in a series is not always related this way. 
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A line chart showing employee ages makes no sense because there is no relationship 
between their name and their age.  If we re-arranged the names (eg sorted them 
alphabetically), the shape of our chart would be completed changed. 
 
Better chart types for this situation include Column, Bar, or even XY Scatter. 
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30. Don’t include series totals in chart data series. 

If you accidentally include the total of a series in the series itself, the last data point will be 
incorrect and the chart will be distorted. 
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In this example, the data series should stop at Q4 but the total has been included 
accidentally, causing a large distortion. 
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DATABASE TABLES 

31. Don’t use the same field name in a database table more than once. 

If you use the same field name (ie column heading) more than once in a database table, 
Excel will still function correctly however the table is more difficult to work with because you 
have to manually keep track of which field is which. 
 
Instead, make sure each heading is unique and your life will be much easier. 
 

 
 

In our sample database, because some field names span 2 lines, Excel thinks the headings 
“FirstName” and “LastName” have been used twice (the database range selected by Excel 
has been highlighted). 
 
So when we come to sort our database, which field is which?  Similarly, if we generate a pivot 
table, which LastName field has been included? 
 

     
 
Without unique names, you can still figure it out but there is much more chance of making a 
mistake. 
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32. Don’t try to use your spreadsheet as a relational database – it won’t work! 

It has been said that the most common database in the world is an Excel spreadsheet! 
 
Whilst Excel is fine for very simple databases, it really struggles when you try to mimic the 
functionality of a relational database because that’s not what it is intended for. 
 
A relational database such as Access is able to easily link multiple records in one database 
table to a single record in another table because it keeps track of the relationships between 
data records (eg one customer can have many shipping addresses etc). 
 
Excel on the other hand just keeps everything in one big table, so it isn’t very good at relating 
a record in one table to other records in another table. 
 
You can do it in a rather awkward fashion using Vlookups, Pivot Tables, and other functions, 
but the chances of making an error and losing data integrity are extremely high. 
 
It’s a case of using the right tool for the job so if your application needs multiple database 
tables, use Access and don’t try to do it in Excel. 

33. If you have tens of thousands records in your database table, it’s probably time to think 
about using Access. 

The absolute maximum number of rows in an Excel worksheet is 65,536 (ie 2
16

).  With Access 
and other database systems, the upper limit is often only defined by the amount of disk space 
you have available. 
 
So if your application has tens of thousands of database records, you may want to start 
thinking about using Access or another database system as these will provide greater 
scalability, and better data integrity. 

34. Don’t allow blank rows and/or columns in database tables. 

When Excel encounters a blank row, it thinks it has reached the end of your database table. 
 
In our example below, Excel doesn’t realise we have more data in rows 7-9. 
 

 
 
This is obviously a bad thing if you wanted Excel to include the full database range (eg if 
you’re re-sorting, doing lookup’s, filtering, pivoting etc).   
 
However, knowing this, you can place rows at the bottom of your table that provide totals of 
the data above but won’t be included in database operations. 
 
With our example, if we remove the blank row and filter the list, the total at the bottom will not 
be filtered out because it is separated from the data by a blank row.  Because we’ve used 
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SUBTOTAL, rather than SUM, the total shown will only add up the values that are visible.  
Note: SUM will always show the total of the cells regardless of whether they’re visible nor not. 
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MISCELLANEOUS 

35. Don’t try to GOTO hidden cells. 

By pressing F5, you can go directly to a cell reference or a named range (amongst many 
other things). 
 
However, if your intended destination is on a hidden sheet, it won’t work.  You won’t get an 
error – just nothing will happen. 
 
So if this happens, check whether there are any sheets that are hidden by going to “Format > 
Sheet > Unhide”. 
 

 
 
In addition, it’s possible to hide a sheet using VBA so its “Very Hidden”.  This means that you 
can’t unhide it via the Format menu – the only way to make it visible again is via more VBA 
code (lookup the “Visible” property in Microsoft Visual Basic online help).  This is useful when 
you want to prevent all users from accessing a particular sheet. 

36. Use manually calculated test data that can independently verify your calculations. 

Just because it’s in a spreadsheet doesn’t mean it’s right!  There could be errors in the data 
or formulas that produce an incorrect result. 
 
Some of the ways to guard against this type of problem include: 

 Perform the calculations manually for some data sets and compare Excel’s results to 
these.  In this way, you can design test data that covers various scenarios and tests as 
many different parts of your spreadsheet as possible. 

 Wherever possible, calculate the results in different ways and compare the results. 
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In this example, we have a crosscheck total calculated in F10 that recalculates the total using 
a different formula.  In addition, the formula at G10 will show either a green “OK” or a red 
“Error” message depending on whether the crosscheck is OK or not. 
 
Even if very small differences occur (such as those from variations in rounding) our formula in 
G10 will still be fine because we have used the INT function, which rounds the result to the 
closest integer (whole number). 
 
We’ve applied conditional formatting (under “Format > Conditional Formatting” in Excel 97 
onwards) to G10 to achieve this as per below: 

 

 
 

37. Layout your spreadsheet in a logical manner and avoid spaghetti referencing (where 
formulas use cells from all over the spreadsheet). 

As much as possible, spreadsheets should be laid out so they read like a book ie from top to 
bottom and from left to right. 
 
As such, avoid referencing cells to the right or below your formula because this will make your 
spreadsheet more difficult to follow. 
 
In general, formulas should always reference cells above them or to their left. 
 
This is one of the potential problem areas identified by Spreadsheet Professional. 

38. If your spreadsheet will be used in multiple locations/environments, make sure you test it 
using all possible international settings, Excel versions, and PC environments and 
possibly on a Mac. 

Although your spreadsheet works fine on your system, if it’s going to be used on systems that 
have different international settings, it may not function correctly. 
 
The different date formats between the US (mm/dd/yyyy) and UK (dd/mm/yyyy) is a well-
known issue but there are many others as well.  For example, in some locales, dates are 
written as dd.mm.yyyy and the number 1234.56 is displayed as “1.234,56”.   
 
Another example is that the US uses Letter sized paper for most printing, while the UK uses 
A4.  While the page sizes are similar, they vary by a significant margin (excuse the pun!). 
 
Different versions of Excel have introduced new features.  If you’re using features that are 
only available in the latest version, you may find errors occur if you use the file on an earlier 
version (assuming you can actually open it!). 
 
Similarly, if your spreadsheet will need to run on a Mac, you can’t hardcode file paths (such 
as “C:\My Documents\”) because a Mac uses “:” instead of “\” as its file path separator. 
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Discussing how to get around all these issues is beyond the scope of this guide – just ensure 
you are aware of the potential problems that can arise and always test your spreadsheet’s 
operation on the intended systems prior to release. 

39. Watch out for hidden rows or columns when copying, pasting, inserting, deleting or 
moving. 

Hiding rows and/or columns you don’t want to see is a very useful feature however, it can also 
lead to problems if you forget they’re there. 
 

 
 
In this example, we’ve hidden row 8 then copied cells A2:F9 down to A12.  Note that even 
though the “Cost of Goods Sold” row was hidden in the source range, it re-appeared when we 
copied it. 
 
Similar issues can arise when pasting data into cells that include hidden rows or columns. 
 

 
 
In this example, we’ve hidden Columns D-F which contain Q3, Q4, and Total data.  If we 
copied in a new set of 4 sales figures for Widgets 1, we would overwrite the two columns of 
visible sales figures, but we would also overwrite the two columns of hidden figures – the data 
wouldn’t be placed into columns G-H. 
 
This may not be what we expected so care must be taken to ensure hidden data is not 
changed in error. 

40. Even if your spreadsheet will only be used by you, include instructions, details regarding 
the workbook’s purpose, author, version, and updates. 

The reason for this is that you may not always be the only person who uses the file.  
Eventually through promotion, resignation, job re-allocation, holidays, sickness or whatever, 
someone else may need to use the spreadsheet you’ve made. 
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When this happens, life will be so much easier if you’ve taken a few moments to write a some 
short instructions about the purpose of the file, who made it, and how it should be used. 
 
Combined with: 

 properly documented code and formulas;  

 separate data entry, calculations, and output areas that can be easily distinguished; and, 

 a logical top-to-bottom, left-to-right layout; 
 
… the person taking over the spreadsheet will come up to speed with it far quicker than if 
these measures were neglected. 
 
An example of a very simple “About” sheet has been included below (as taken from the file 
we used to store most of the examples shown in this guide). 
 
As you can see, it is not elaborate or particularly lengthy in this case since the purpose of the 
file is very straightforward.  However, if someone else ever needs to refer back to it, they will 
know exactly what the file was used for, who made it, and what version amendments have 
been made. 
 
You don’t have to use the example format provided exactly – you may have another format 
that is more suitable.  The main point is to include this type of information somewhere in your 
files. 
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VBA MACROS 

41. Don’t hardcode cell or range addresses in VBA macros. 

Hardcoding cell references can cause errors to occur and other unexpected behaviours if an 
additional row or column is inserted because your macro now refers to incorrect cell 
addresses. 
 
A better way is to use named ranges in VBA macros as these can be moved, and/or resized 
without affecting your macros. 
 

 

42. Ensure your custom menus don’t use the same initial letter more than once. 

If you use custom menus, you have the option of making a keyboard shortcut that will access 
each menu item.  Your custom menus can be setup in the same way as Excel’s standard 
menu bar, which has File Edit etc accessible via ALT-F, ALT-E etc. 
 
The difficulty for Excel arises where there are two menu items with the same keyboard 
shortcut.  When this happens, Excel doesn’t know what to do. 
 

     
 
In the first example, both “Cashflow” and “Cashflow Chart” have been setup to use the ALT-C 
shortcut, while both “DataInput” and “Disclaimer” are accessed via ALT-D.  Both these errors 
have been fixed in the second example. 
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43. If others will use your spreadsheet, protect your sheets and VBA modules via password – 
only allow others to make changes where you want them to. 

Whilst it’s a whole lot better than it used to be, Excel currently isn’t huge on security and there 
are services around that will crack whatever passwords you place on your files … if someone 
is really motivated. 
 
However, you can make your files reasonably secure by implementing passwords to open the 
file (available under “File > Save As > Tools > General Options”), protect worksheets (under 
“Tools > Protection > Protect Sheet” or “Protect Workbook”), and view your VBA code (under 
“Tools > VBAProject Properties > Protection”). 
 

 
Implementing Open or Modify file passwords. 

 
If you need ultimate security, place your code inside a COM Add-in (get a good book on Excel 
VBA in order to find out how to do this!). 

44. Ensure your buttons and controls are linked to macros and/or cell references. 

If your buttons aren’t linked to macros, they won’t work!  When you click on the button, you’ll 
start to edit it rather than run a macro. 
 
Similarly, if controls such as drop down boxes don’t have a source, they’ll be blank. 
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45. If you use a custom status bar message, make sure you reset it. 

Updating the status bar is a useful way of passing messages to a user while your macro is 
running.  This is accessible via Application.StatusBar = “My Message” 
 
However if your macro ends and it hasn’t reset the status bar (via Application.StatusBar = 
False) the status bar will continue to show whatever message you last set it to – even after 
your macro has finished running. 
 

 
 

46. Watch out for endless loops. 

Sometimes you may inadvertently create an endless loop, which may keep going forever or 
until it creates an error. 
 
Obviously you want to avoid this in most situations, however you can interrupt your code 
execution at any time by pressing Ctrl-Break or ESC. 

47. Always document your code. 

It sounds obvious but it’s a step that is often ignored. 
 
Well-documented code makes life so much easier when you have to maintain it or when 
someone else has to take over your work. 

48. As much as possible, write code and functions that are modular and can be easily re-
used. 

Wherever possible, look for ways to reuse code and functions – think about ways in which the 
functions could be used in other spreadsheet files. 
 
The advantages are that it saves you an awful lot of time if you don’t need to reinvent the 
wheel and can simply copy and paste code segments between projects. 
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49. Always use “Option Explicit”, but use “On Error Resume Next” and “GOTO” sparingly. 

“Option Explicit” forces you to declare your variables via “Dim” statements (eg “Dim 
StartSalary as Integer” etc) before they are used. 
 
The main benefits of this are:  

 that spelling errors are automatically detected eg if you type “StarSalary = 20000” and try 
to run the macro, it will detect that this variable hasn’t been declared rather than thinking 
that you’re just referring to a new variable; and  

 your code will run slightly faster because you have told Excel what type of variable 
“StartSalary” is (ie an Integer in this case). 

 

 
 

Under “Tools > Options > Editor”, you can check the “Require Variable Declaration” box and 
Excel will automatically add “Option Explicit” to all new modules you create (note that existing 
modules will not change). 
 
“On Error Resume Next” is a very useful way of getting Excel to try and do something 
because even if it doesn’t work, no error message will be produced and you can then test 
whether the action worked or not by using code. 
 
This same usefulness can also be a hindrance if not implemented properly because important 
errors that occur in your code could go undetected resulting in unexpected behaviour. 
 
As such, turn error reporting back on as soon as possible after an “On Error Resume Next” 
statement so any errors that occur are highlighted.  To reset what happens when an error 
occurs, use “On Error Goto 0”.  
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In this example, we use “On Error Resume Next” to skip any error messages that may result if 
Excel isn’t able to open the text file selected by the user.  However, we then test whether an 
error occurred using our own code and handle this accordingly.   
 
Error reporting is turned back on immediately after it is no longer required. 

50. Use clear, systematic variable names. 

Excel lets you call your variables and functions anything you want, apart from certain names 
that are used by VBA itself.  However, your code is much easier to read if you have a system 
for naming variables and functions. 
 
So instead of “Dim Count As Integer”, you could write “Dim intCount as Integer”.  Then, every 
time you see intCount, you know that it contains an integer. 
 
You can really adopt whatever system you want.  So long as you’re consistent in applying it, 
you’ll get the benefits. 
 
Gregory Reddick has developed a formalised VBA naming convention that has become a 
defacto standard.  See http://www.xoc.net/standards/rvbanc.asp  
 
You may also want to adopt a naming convention for range names used in your file eg all 
range names on your data configuration sheet have the prefix “config”. 

51. Disable screen updating when running macros. 

Your macros will run much faster and you’ll eliminate any distracting screen flickering if you 
disable screen updating in any macros that update components of your worksheet (eg copy, 
paste, insert, delete etc). 
 
You can turn screen updating off via “Application.ScreenUpdating = False”. 

http://www.xoc.net/standards/rvbanc.asp
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52. Don’t use the macro recorder alone to write all your code. 

The macro recorder (under “Tools > Macro > Record New Macro”) is a great way of learning 
Visual Basic for Applications (“VBA”).  However, like many automatic code generators, it 
doesn’t always produce the most efficient code. 
 
The macro recorder always hardcodes cell references and will often produce lengthy code 
that may be difficult to read. 
 
You’ll find that you can shorten a lot of the code it generates to make your code clearer.  In 
any event, you’ll want to add your own comments to it so you remember what is going on. 
 

 
 
In this example, the Macro Recorder was used to record Macro2 which simply copies the 
values from B3:C9 to H3.  Macro2Abbreviated does exactly the same thing but was written by 
hand.  As you can see, hand coding produces much simpler and shorter code. 
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Additional resources 
Here is some additional information that you may find useful regarding financial modelling. 
 

Area Suggested Resources 

Financial Modelling and 
Management Reporting 

To see how we could help with your project or issue, call us on 
+61 8 6210 8500, e-mail consulting@accessanalytic.com.au or 
visit 
http://www.accessanalytic.com.au/services_excel_web.php  

Financial model audit and review We provide an independent model audit service to highlight any 
potential errors or inconsistencies. 
 
If you’d like to sleep better knowing that your key Excel models 
are giving you the right answer, call us on +61 8 6210 8500, e-
mail consulting@accessanalytic.com.au or visit 
http://www.accessanalytic.com.au/services_excel_audit.php  

Automated Spreadsheet 
Auditing Tools 

We use and highly recommend Spreadsheet Professional as a 
great tool to use in-house if you are going to be reviewing 
spreadsheets on a regular basis. 
 
For more information, call us on +61 8 6210 8500, e-mail 
consulting@accessanalytic.com.au or visit 
http://www.accessanalytic.com.au/services_spro.php  

Training We provide high-powered training in Financial Modelling, VBA 
and advanced Excel for accounting and finance professionals 
throughout the Asia-Pacific region. 
 
For more information, visit 
http://www.accessanalytic.com.au/training   

Excel Mentoring Personalised mentoring in your office, using your files, solving 
your issues. 
http://www.accessanalytic.com.au/services_mentor.php  

 
Access Analytic ® is a registered trademark of Access Analytic Solutions Pty Ltd 
Excel ® is a registered trademark of Microsoft 

mailto:consulting@accessanalytic.com.au
http://www.accessanalytic.com.au/services_excel_web.php
mailto:consulting@accessanalytic.com.au
http://www.accessanalytic.com.au/services_excel_audit.php
mailto:consulting@accessanalytic.com.au
http://www.accessanalytic.com.au/services_spro.php
http://www.accessanalytic.com.au/training
http://www.accessanalytic.com.au/services_mentor.php
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Further Reading 
Additional information on spreadsheet modelling best practices: 

Best Practice Modelling Standards, Spreadsheet Standards Review Board 
http://www.ssrb.org/  

Spreadsheet Modelling Best Practice, IBM & PwC http://www.eusprig.org/smbp.pdf  

How do you know your Spreadsheet is Right http://www.eusprig.org/hdykysir.pdf  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.ssrb.org/
http://www.eusprig.org/smbp.pdf
http://www.eusprig.org/hdykysir.pdf
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Access Analytic Overview 

OVERVIEW 

Access Analytic provides AMAZING Excel solutions to enable companies to grow, control 
their costs and reduce their risks. 
 

 

Figure 1: Access Analytic Solutions Overview 

Our Services fall into three groups: 

 Helping Companies Grow: 

 Process Improvement: streamlining processes to create flexible, scalable 
processes. 

 Financial Modelling: to forecast results (e.g. equity/loan capital raising, business 
planning, feasibility studies, project economics etc.) with sensitivity and scenario 
analysis to support decision-making with confidence. 

 Reporting: tailored dashboards and KPIs using Excel and Power BI to connect to 
both cloud and on-premise data, thereby allowing companies to keep on top of their 
operations, gain insights, and make data-driven decisions. 

 Training: training in all of these areas to transfer skills to support further growth. 

 

 Helping Companies Control Cost 

 Process Improvement: efficient Excel-based processes that reduce the need for 
manual input. 

 Financial Modelling: Excel-based budgeting and forecasting systems that enable 
companies to efficiently control and monitor their costs. 

 Reporting: reporting to assist Finance, Human Resources and Operations with their 
areas of responsibility for cost control. 

 Training: assisting staff to become more productive and reduce the need for 
additional resources.  Courses are provided on an in-house basis, which often results 
in a cost saving of 50% or more compared to public courses. 
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Helping Companies Reduce Risk 

 Process Improvement: by automating processes, companies not only save time, 
they also reduce the errors and risks that result from manual inputs.  This results in 
more accurate data, which can provide better analysis. 

 Financial Modelling: independent model auditing services to provide assurance that 
key models are producing accurate results and can be relied upon. 

 Reporting: reporting that focuses on the right data at the right time to provide 
transparency & visibility. 

 Training: financial modelling best practices to reduce risk and improve quality. 
 
We are based in Perth, Western Australia and the business was established in 2000. 
 
Access Analytic provides services to clients located in: Australasia, Asia, Africa and the 
Middle East.  A selection of our clients is shown below: 
 

 

ACCESS ANALYTIC: RISING STAR 

 
 
Access Analytic was named as one of the WA Business News’ Rising Stars for 2012, 
recognising the success and achievements of our company. 
 
Further details regarding Access Analytic Solutions have been included at Appendix A: 
Access Analytic Details on page 41 below. 
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KEY STAFF 

Jeff Robson, Principal Business Analyst 

Masters (Applied Finance), BCom (Accounting & Information Systems), CISA, MAICD, 
FAIM, F Fin, Microsoft Excel Expert 
 
Jeff is the founding Director and Principal Business Analyst at Access Analytic 
Solutions. He has over 20 years’ experience in chartered accounting, business 
management and consulting. 
 
Jeff holds a Masters in Applied Finance and is a Certified Information Systems 
Auditor. He is highly regarded and recognised around the world as an expert in 
the field of financial modelling.  
 
His achievements have been recognised by his peers and he is a Fellow of both 
the Financial Services Institute of Australasia and the Australian Institute of Management. 
 
Jeff has extensive experience in best practice financial modelling, management reporting, 
business analysis, and spreadsheet auditing and is also an entertaining international 
presenter and trainer on these subjects. 

Wyn Hopkins, Senior Manager 

B.Sc. (Hons) Accounting & Financial Management, CA, MS Excel Expert 

Wyn gained his Chartered Accountant qualification at 
PricewaterhouseCoopers in the UK in 2000. 
 
He has extensive Business Analyst experience in FTSE 100 financial services 
companies (HBOS and Barclays in the UK) as well as GESB in Perth and 
telecommunications companies industry in Australia. 
 
Wyn is skilled in financial analysis, strategic financial modelling, management 
reporting and forecasting, and value-based management techniques. 
 

Yury Tokarev (Manager) 

CA, PhD (Finance & Economics), GradDip (Accounting), BBS, Microsoft Excel Expert 

Yury joined Access Analytic from WHK Chartered Accountants, where he was 
involved in business services and advisory for four years. 
 
Prior to this, he worked as a Corporate Finance Consultant at one of the top 
European Investment Banks. 
 
Yury has highly advanced skills in Excel and financial modelling, including 
complex financial models and the development of VBA macro solutions. 
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Anthony Kitson, Senior Business Analyst (Contract) 

Chartered Accountant (CA), B.Bus (Accounting & Finance), B.Eng (Electronics & 
Comms), CISA, Prince2 Practitioner 

 
Anthony has extensive expertise in consulting and business management, with 
over 25 years in combined experience.   
 
He specialises in the areas of Financial Modelling, Data Analytics, reporting, 
revenue leakage, Business Intelligence, and Information Management.  
 
Anthony’s experience has been gained across the Government, Energy, Power 
& Natural Resources, Financial Services, and Industrial sectors.  
 
He has specialised expertise in financial modelling for mining, including building and 
reviewing models for Bank Feasibility Studies, project finance, consolidated corporate 
models, production planning and workforce planning. 
 
 

Neale Blackwood, Senior Business Analyst (Contract) 

CPA, B.Bus (Accounting), Microsoft Excel Expert 

Neale is a CPA with over 20 years’ experience in accounting, budgeting, 
management reporting, and developing spreadsheet applications.  
 
Neale has extensive experience across a broad range of industries including 
mining, education, property, forestry, government, and construction. 
 
Neale is the CPA magazine’s authority on spreadsheets and related subjects, 
and writes a monthly column for this publication.  
 
He is also a sought-after speaker and trainer regarding the use of Excel, 
particularly by accountants. 

Brett Rawcliffe, Senior Database Analyst (Contract) 

MACS 

Brett is a highly experienced database analyst and is regularly in contact with Microsoft 
regarding their database software. 
 
Over the last 13 years Brett has developed hundreds of database solutions for companies of 
all sizes, from sole traders needing a simple contact manager to multi-nationals needing to 
develop specialised systems to complement their organisation-wide systems.  
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Appendix A: Access Analytic Details  

Access Analytic Solutions Details 

Full Name: Access Analytic Solutions Pty Ltd 

Address: Suite 143, Level 1 580 Hay St 
Perth WA 6000 
Australia 

Phone: +61 8 6210 8500 

Fax: +61 8 6210 1662 

Web: www.accessanalytic.com.au  

ACN: 091 625 697 

ABN: 64 091 625 697 

Contact: Jeff Robson, CEO 
E: jrobson@accessanalytic.com.au 
M: +61 4 1258 1486 

 
 
 

http://www.accessanalytic.com.au/
mailto:jrobson@accessanalytic.com

